X
24836

Ticket #24836 Public [Closed]

Sync on PHP 5.3?

  • Hi there!

    I love the plugin design and how it works — great job!

    I ran into a problem with our IT department still not having updated to PHP 5.4, and I would really like to use Google Calendar sync. Is there any way I can sync Google Cal on PHP 5.3.xx?

    Thanks!

    -John

    BY: aslanj - Jan 23,2017 AT 1:25PM - 3 years ago
    • By: infotainerdave Jan 23,2017 AT 11:58PM - Posted 3 years ago - #24916

      PHP 5.3 – Released 30 June 2009 and retired 14 Aug 2014 (Last release 5.3.29) – Launched 7 years ago, and retired 1.5 years ago.

      the latest version of eventon is 2.5 and is designed to go with PHP7

      you’ll want to update from 5.3 because there are security issues with it and things run slower- 2 very good reasons to update

      There are no more security updates for PHP 5.2, 5.3, or 5.4. Ouch.

      Your leaving yourself open to hackers with 5.3 and if you have ever been hacked – it’s not a fun thing to happen

       

    • By: aslanj Jan 24,2017 AT 6:56PM - Posted 3 years ago - #25203

      Thanks for the response!

      I understand the problems of not upgrading PHP. However, my problem is that our IT department is in charge of the servers and they are currently using PHP 5.3.xx (a modified version of it). I was hoping there would be a way to allow EventON Sync addon to work with PHP 5.3, like tricking WordPress to make the addon think it has PHP 5.4 maybe?

    • By: infotainerdave Jan 24,2017 AT 6:57PM - Posted 3 years ago - #25204

      Thank you for your messages, I am going to assign this ticket to Ashan and he will be able to take it from here and find you a solution. Please allow some time for him to get back to you, we greatly appreciate your patience and thank you for being a eventon customer!

    • By: Ashan Perera Jan 25,2017 AT 11:30AM - Posted 3 years ago - #25399

      I am sorry my friend the PHP requirement is something we can not remove because that is what is needed by the API’s we are using. You can try our ICS or CSV impoter addons as an alternative if you can find way to get those events in that format.

      But yea unfortunately PHP requirement is a must.

    • By: aslanj Jan 28,2017 AT 7:12PM - Posted 3 years ago - #25749

      Thanks for your response, Ashan. It seems I will be able to move my site to a new environment with php7. So, hopefully, it will all work out.

      Thanks again.

You must login to reply to this ticket

HelpDesk

Welcome to EventON helpdesk.

EventON is the #1 Best selling event calendar plugin for WordPress websites in envato marketplace.

Checkout EventON