X
33401

Ticket #33401 Public

***URGENT** WooCommerce Upgrade

  • HI we have an urgent request involving an upgrade to our webiste. We did not see the notice you have added on support and went ahead and upgraded to WooCommerce 3. Now we cannot see the events or find how many people are due to attend. Is there any way to recover from this. Your urgent help would be most appreciated.
    Mike

    BY: mikehawkey - Apr 6,2017 AT 3:52AM - 3 years ago
    • By: mikehawkey Apr 6,2017 AT 4:07AM - Posted 3 years ago - #33406

      Here is what I am seeing:

      Fatal error: Uncaught exception ‘Exception’ with message ‘Invalid order.’ in /home/vantagep/public_html/events2/wp-content/plugins/woocommerce/includes/data-stores/abstract-wc-order-data-store-cpt.php:86 Stack trace: #0 /home/vantagep/public_html/events2/wp-content/plugins/woocommerce/includes/class-wc-data-store.php(143): Abstract_WC_Order_Data_Store_CPT->read(Object(WC_Order)) #1 /home/vantagep/public_html/events2/wp-content/plugins/woocommerce/includes/abstracts/abstract-wc-order.php(109): WC_Data_Store->read(Object(WC_Order)) #2 /home/vantagep/public_html/events2/wp-content/plugins/eventon-tickets/includes/class-functions.php(485): WC_Abstract_Order->__construct(‘439’) #3 /home/vantagep/public_html/events2/wp-content/plugins/eventon-tickets/includes/admin/class-meta_boxes.php(368): evotx_functions->get_customer_ticket_list(‘242’, ‘243’, ‘all’) #4 [internal function]: EVOTX_post_meta_boxes->evotx_metabox_content(Object(WP_Post), Array) #5 /home/vantagep/public_html/events2/wp-admin/includes/template.php(1048): call_use in /home/vantagep/public_html/events2/wp-content/plugins/woocommerce/includes/data-stores/abstract-wc-order-data-store-cpt.php on line 86

    • By: infotainerdave Apr 6,2017 AT 6:15AM - Posted 3 years ago - #33429

      we are aware of the issue and Ashan is working 24/7 to get the fix. in the mean time

      can you roll back to the previous version? as in deactivate/delete and upload the old version and activate?

      I found this page–  BAck up your site before doing ANYTHING!!!!!!!! I cannot stress this

      I don’t know if this will add anything else on your site
      http://download.openpkg.org/components/cache/wordpress-plugins/

      I don’t know anything about it as all my sites are client site and I don’t want to test it but they appear to have 2.6.14 – I don’t know how legit the site is

      scroll down to to 2.6.14 at https://github.com/woocommerce/woocommerce/releases

      I wouldn’t download the versions above it as they were test versions until the released version 3.0 so go for 2.6.14 which is 2.2MB     (and the openpkg.org version is 2MB) so I would trust the github version

       

      Back up your site before doing anything!!!!!!! if you are hosted on Siteground they have a plugin roll back service and can roll back a single plugin in 30 minutes or so

       

      back up your site!!!!!!!!!!!!!! woocommerce seems to upgrade databases when they do major releases to woocommerce core

      we are working on the solution

    • By: stephengarratt Apr 6,2017 AT 7:31AM - Posted 3 years ago - #33457

      I also have this problem. I didn’t think to check the support page here before updating to WooCommerce 3.0. I have now upgraded and the ticket plugin is broken. How long before the fix is rolled out? I really don’t want to risk rolling back WooCommerce.

    • By: infotainerdave Apr 6,2017 AT 7:38AM - Posted 3 years ago - #33459

      we work fast but with any plugins you never update as soon as the next version is available unless there is a super major security issue with the old version.

      it could be a day it could be a few days- depends on just how much woocommerce has changed the plugin- but we do have the plugin creator working on the fix as his sole purpose at the expense of other topics if that helps

    • By: Ashan Perera Apr 6,2017 AT 8:12AM - Posted 3 years ago - #33473

      We have already issued an update to tickets addon v1.5.1 please try that and let us know if there are stil more issues with that version.

    • By: mikehawkey Apr 6,2017 AT 8:43AM - Posted 3 years ago - #33486

      I have upgraded to v1.5.1 which got rid of the error BUT now I don’t have the export CSV option and I can’t get rid of the ‘ EventON Tickets is NOT active! – You do not have EventON main plugin, which is REQUIRED.’ Yet it is active and the licence code is in there. Just to complicate matters further all the events are now showing the author as someone who has tried to by a ticket!

      Mike

    • By: mikehawkey Apr 6,2017 AT 8:44AM - Posted 3 years ago - #33487

      P.S ..and of course you can no longer by a ticket because its saying Eventon isn’t active which it is.

    • By: Ashan Perera Apr 6,2017 AT 8:47AM - Posted 3 years ago - #33488

      Whats the wp-admin login url? also please send FTP access to your site as private and i can get those fixed for you 🙂

    • By: mikehawkey Apr 6,2017 AT 9:01AM - Posted 3 years ago - #33496

      P.P.S Just ugraded Eventon to the latest version and error is back and the option to buy tickets is missing and you can’t move slider.

    • By: Ashan Perera Apr 6,2017 AT 11:20AM - Posted 3 years ago - #33544

      wp-admin login infor is incorrect and can not login to your wp-admin still

    • By: stephengarratt Apr 6,2017 AT 12:05PM - Posted 3 years ago - #33556

      I have upgraded to the new version of the plugin v1.5.1 and I still have the error. I am going to open a separate ticket in which I will add Admin login details.

    • By: Ashan Perera Apr 6,2017 AT 7:47PM - Posted 3 years ago - #33573

      Guys look at this https://wordpress.org/support/plugin/woocommerce/reviews/ really bad everyone is hating their update.

      You guys should find a way to get back to WC older version. Until they iron out the errors in next 3-4 version releases. And go to tickets 1.5 tickets. 1.5.1 i made it compatible with WC3 and its not backward compatible because the new functions they use doesnt have a backward compatibility.

      Woocommerce really pulled a fast one with this update. They basically removed several functions and action hooks and add new ones so everyone using WC have to use these new functions. Including their own addons. Big one is the action hook called woocommerce_add_cart_item_data is no more and this is used by all their addons and event tickets addon.

      This is a huge slap in WC customers face. Because now all the customers have to buy their addons again – if the 1 year license is expired. And here at eventON our addon license are good for life no need for this after a year! So yea talk about tricking and forcing their customers into rebuying the addons.

      Anyways we will keep up with the new improvements in WC and as soon as we have a stable tickets version we will get it out.

       

You must login to reply to this ticket

HelpDesk

Welcome to EventON helpdesk.

EventON is the #1 Best selling event calendar plugin for WordPress websites in envato marketplace.

Checkout EventON